
BAB III 

PERANCANGAN SISTEM 

 

Setelah melakukan definisi masalah dan mempelajari teori-teori yang 

mendukung maka selanjutnya ialah merancang sistem yang dibutuhkan untuk 

memudahkan implementasi sistem yang akan dibuat. Hal ini bertujuan agar 

aplikasi yang akan dibuat dapat berjalan sesuai dengan yang diharapkan. 

Perancangan sistem yang baik pada suatu masalah akan ikut mempengaruhi 

kualitas aplikasi yang dibuat, termasuk interface (antar muka) aplikasi. Dalam 

tahap perancangan sistem ini, terdapat dua hal yang perlu diperhatikan yaitu 

analisis sistem dan desain sistem. 

 
3.1. Analisis Sistem 

Tahap analisis ini dilakukan untuk mengetahui kebutuhan aplikasi yang 

akan dibuat. Dari hasil analisis ini, dapat didesain perangkat lunak dalam 

merancang sebuah aplikasi yang memenuhi tujuan dan menyelesaikan masalah. 

Karena aplikasi ini bertujuan untuk memodifikasi Windows melalui 

registry, maka diperlukan informasi mengenai letak dari key atau value pada 

registry yang memegang peranan fungsi yang dibutuhkan pada Windows. Hal ini 

sangat diperlukan karena apabila terjadi kesalahan dalam merubah registry, maka 

hal yang didapat ialah Windows yang tidak berjalan normal. 

Setelah mengetahui letak dan fungsi dari key atau value, maka diperlukan 

informasi mengenai jenis perubahan apa yang harus dilakukan pada key atau 

value tersebut agar dapat memberi perubahan pada Windows. Apakah perubahan 
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yang diperlukan berupa pembuatan data baru, penghapusan data baru atau update 

data dari key atau value tersebut. 

Di dalam registry tersimpan hampir semua data mengenai konfigurasi 

Windows, sehingga hampir semua perubahan untuk Windows dapat dilakukan 

melalui registry dan itu berarti terdapat banyak fungsi pada registry yang dapat 

digunakan untuk memodifikasi Windows. Oleh karena itu pemilihan fungsi 

difokuskan pada fungsi-fungsi yang sekiranya umum untuk digunakan pada 

pengguna yang telah dijelaskan pada latar belakang masalah. 

 
3.2. Desain Sistem 

Tahap selanjutnya dilakukan desain sistem. Pada tahap desain sistem ini 

akan membahas hal-hal sebagai berikut yaitu fungsi-fungsi registry yang akan 

diterapkan pada sistem, prosedur Windows API yang akan digunakan dalam 

sistem, dan desain user interface untuk sistem. 

 
3.2.1. Fungsi-fungsi Registry untuk Sistem 

Adapun fungsi-fungsi yang akan diterapkan pada sistem dan telah 

dikelompokkan sebanyak 12 kategori ialah sebagai berikut: 

 
A. Accessories 

1. Menonaktifkan Windows XP Tour. 

2. Aktifkan Word Wrap pada Notepad. 

3. Menyimpan posisi Window Notepad. 

4. Menggunakan Notepad untuk membuka File yang belum terasosiasi. 

5. Tampilkan Detailed Information pada Device Manager. 

6. Tampilkan Hidden Devices pada Device Manager. 
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7. Menonaktifkan Task Manager (tombol Ctrl+Alt+Del). 

8. Aktifkan Smooth Scrolling pada Telnet. 

9. Mengaktifkan tombol "Tab" untuk Command Completion pada DOS 

Prompt. 

10. Menambah teks pada DOS Command Prompt. 

11. Menambah akses ke DOS Prompt pada Menu Konteks. 

12. Mengaktifkan Quick Edit pada DOS Command Prompt. 

13. Menonaktifkan Command Processor Extensions pada DOS Prompt. 

14. Menonaktifkan Windows Installer (MSI). 

15. Aktifkan pengendali jarak jauh Windows Installer (MSI) untuk 

administrator. 

16. Aktifkan Windows Installer (MSI)  Logging. 

17. Menonaktifkan Registry Editor (Regedit). 

 
B. Appearance 

1. Mengubah posisi Desktop Wallpaper. 

2. Mematikan Picture Viewer Windows XP. 

3. Setting Thumbnail Image. 

4. Aktifkan Smooth Scrolling. 

5. Tampilkan Windows Contents pada saat Drag. 

6. Aktifkan Feature Personalized Menus. 

7. Mengatur kecepatan tampilan Start Menu. 

8. Aktifkan Font Smoothing. 

9. Menghilangkan Tool Tips pada tombol Minimize, Maximize dan Close. 

10. Aktifkan animasi Minimize/Maximize Window. 
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11. Setting tampilan warna Desktop Icons. 

12. Setting ukuran Icon pada Desktop. 

13. Otomatis menampilkan Thumbnails File Bitmap. 

 
C. Control Panel 

1. Menonaktifkan Control Panel 

2. Menghilangkan "Administrative Tools" dari Control Panel. 

3. Menghilangkan "Taskbar and Start Menu" dari Control Panel. 

4. Menghilangkan "Folder Options" dari Control Panel. 

5. Menghilangkan "Network Connections" dari Control Panel. 

6. Menghilangkan "Fonts" dari Control Panel. 

7. Menghilangkan "Scheduled Tasks" dari Control Panel. 

8. Menghilangkan "Scanners and Cameras" dari Control Panel. 

9. Menghilangkan "Control Panel", "Printer" dan "Network Settings" dari 

Classic Start Menu. 

10. Memaksa tampilan Control Panel menjadi tipe tampilan Classic. 

11. Memaksa tampilan Control Panel menjadi tipe tampilan XP. 

12. Menonaktifkan Add/Remove Programs. 

13. Menghilangkan bagian "Changes or Remove Programs" dari Add/Remove 

Programs. 

14. Menghilangkan bagian "Add New Programs" dari Add/Remove Programs. 

15. Menghilangkan bagian "Add/Remove Windows Components" dari 

Add/Remove Programs. 

16. Menghilangkan bagian "Set Program Access and Defaults" dari 

Add/Remove Programs. 
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17. Menghilangkan bagian "Add a program from CD-ROM or floppy disk" 

dari Add/Remove Programs. 

18. Menghilangkan bagian "Add a program from Microsoft" dari Add/Remove 

Programs. 

19. Menghilangkan bagian "Support Info" dari Add/Remove Programs. 

20. Menonaktifkan Display Setting. 

21. Menghilangkan tab Themes dari Display Properties. 

22. Menghilangkan tab Desktop dari Display Properties. 

23. Menghilangkan tab Screen Saver dari Display Properties. 

24. Menghilangkan tab Appearance dari Display Properties. 

25. Menghilangkan tab Settings dari Display Properties. 

26. Menonaktifkan kontrol "Windows and buttons" pada Appearances Display 

Properties. 

27. Menonaktifkan kontrol "Color scheme" pada Appearances Display 

Properties. 

28. Menonaktifkan kontrol "Font size" pada Appearances Display Properties. 

29. Menonaktifkan "Hide underlined letters for keyboard navigation until I 

press the ALT key" pada Display Properties. 

30. Menonaktifkan pilihan "use the following transition effect for menu and 

tooltips" pada Display Properties. 

31. Menonaktifkan penambahan Printer. 

32. Menonaktifkan penghapusan Printer. 

33. Menghilangkan Applets yang terdapat pada Control Panel. 
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D. Desktop 

1. Menghilangkan "My Computer" dari  Desktop dan Start Menu. 

2. Menghilangkan "Internet Explorer" dari Desktop. 

3. Menonaktifkan klik kanan pada Desktop. 

4. Tampilkan versi Windows pada Desktop. 

5. Menampilkan nama user dan nama komputer pada Icon My Computer. 

6. Membuat proses tersendiri untuk Windows Desktop. 

7. Menampilkan Pop-up deskripsi untuk Explorer dan Desktop Items. 

8. Menonaktifkan Desktop Cleanup Wizard. 

9. Aktifkan Desktop Cleanup Wizard setiap pada periode tertentu. 

10. Menentukan waktu jeda pengaktifan Password Screen Saver. 

11. Menghilangkan semua Item dari Desktop. 

12. Membuat Desktop yang aman. 

13. Menonaktifkan fasilitas untuk mengganti Wallpaper. 

14. Menonaktifkan default Screen Saver. 

15. Menonaktifkan pilihan proteksi Password Screen Saver. 

16. Menghilangkan/Menonaktifkan Properties My Computer (System 

Properties). 

17. Menghilangkan/Menonaktifkan Properties Recycle Bin. 

18. Menghilangkan tab Hardware pada Device Properties. 

19. Menghilangkan gambar panah Shortcut pada Desktop. 

20. Menambah lembar "Clock Frequencies" pada Display Properties Nvidia – 

GeForce. 
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E. File System 

1. Hapus file secara permanen tanpa melalui "Recycle Bin". 

2. Meningkatkan performa sistem utama (Core System). 

3. Aktifkan CD-R(W) dan DVD-R(W) AutoRun. 

4. Mematikan Autorun untuk semua tipe Drive. 

5. Menonaktifkan fungsi Autorun CD-ROM. 

6. Menonaktifkan feature Internal CD Burning pada Windows XP. 

7. Selalu Unload file DLL dari Memory. 

8. Optimalkan ukuran System Cache. 

9. Menyesuaikan Disk Cache sesuai dengan jumlah RAM yang dimiliki. 

10. Mengaktifkan Boot Disk Optimization / Defragmentasi file Start. 

11. Menonaktifkan peringatan "Low Disk Space". 

12. Menonaktifkan bunyi 'Beep' PC speaker. 

13. Merubah perangkat Disk IEEE 1394 (Firewire) menjadi Dynamic Disk 

Drive. 

14. Aktifkan Mode UDMA66 pada Chipset Intel. 

15. Aktifkan 48-bit LBA untuk mendukung Hard Disk berkapasitas lebih dari 

137 GB. 

16. Menonaktifkan pengiriman peringatan sisa kapasitas HardDisk. 

17. Aktifkan Mouse Active Window Tracking. 

18. Menghentikan peringatan untuk resgritasi Online. 

19. Maksimalkan jumlah memory yang dialokasikan untuk Java Virtual 

Machine. 

20. Mempercepat Loading file DLL. 
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21. Auto Restart Shell Windows. 

22. Meningkatkan waktu USB Polling Interval. 

23. Menyembunyikan option "Computer Management". 

24. Menonaktifkan Popup Error Messages. 

25. Mengatur pilihan Default Virtual Machine. 

26. Menonaktifkan Windows Script Host. 

27. Menampilkan konfirmasi keamanan sebelum menjalankan Windows 

Script. 

28. Setting akses untuk Removable Drives. 

29. Setting akses untuk Floppy Drives. 

30. Setting akses untuk CD-ROM. 

31. Menonaktifkan Group Policy Objects. 

32. Larangan akses ke dalam Base System Objects. 

33. Menonaktifkan subsistem OS/2 dan POSIX. 

34. Prompt password jika akan melanjutkan dari mode Hibernate atau mode 

Suspend. 

35. Larangan akses account Guest ke Event Logs. 

 
F. Internet Explorer 

1. Mempercepat loading/membuka Internet Explorer. 

2. Merubah teks Window Title Internet Explorer. 

3. Aktifkan pembatasan berbasis sistem (All User) untuk Internet Explorer. 

4. Melarang perubahan pada Browser Bar Internet Explorer. 

5. Menonaktifkan menu File > New > Window. 

6. Menghilangkan beberapa sub menu pada menu File > New. 
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7. Menonaktifkan menu File > Open. 

8. Menonaktifkan menu File > Save As... 

9. Menonaktifkan "Save As Web Page Complete". 

10. Menonaktifkan menu File >Print dan Print Preview. 

11. Menonaktifkan fitur menu File > Import and Export  Internet Explorer. 

12. Aktifkan Personalized Menu pada menu Favorites. 

13. Menonaktifkan Favorites. 

14. Menghilangkan menu Tools > Mail and News. 

15. Menghilangkan menu Tools > Windows Update. 

16. Merubah teks Windows Update pada menu Tools > Windows Update. 

17. Menonaktifkan menu Tools > Internet Options. 

18. Menonaktifkan menu Help. 

19. Menonaktifkan perintah "Close" pada Internet Explorer. 

20. Menonaktifkan klik-kanan konteks menu. 

21. Menonaktifkan Option Open in New Window. 

22. Menonaktifkan fungsi Full Screen. 

23. Menonaktifkan fungsi View Source. 

24. Menonaktifkan Caching untuk halaman Web yang menggunakan SSL. 

25. Menonaktifkan Password Caching pada Internet Explorer 

26. Menghapus Temporary Internet Files pada saat menutup Internet Explorer 

27. Menghapus sisa alamat web yang pernah dikunjungi. 

28. Menonaktifkan Find Files. 

29. Menonaktifkan akses file melalui Internet Explorer URL/Address Bars. 

30. Menonaktifkan Download file pada Internet Explorer. 
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31. Menonaktifkan pilihan untuk memilih direktori download. 

32. Selalu konfirmasi pada User pada saat Download File. 

33. Menghilangkan tab General dari Internet Explorer Options. 

34. Menghilangkan tab Security dari Internet Explorer Options. 

35. Menghilangkan tab Privacy dari Internet Explorer Options. 

36. Menghilangkan tab Content dari Internet Explorer Options. 

37. Menghilangkan tab Connections dari Internet Explorer Options. 

38. Menghilangkan tab Programs dari Internet Explorer Options. 

39. Menghilangkan tab Advanced dari Internet Explorer Options. 

40. Menambah gambar latar untuk Internet Explorer Toolbar. 

41. Mengunci Toolbar Internet Explorer. 

42. Menonaktifkan konteks menu "Customize..."  pada Toolbar Internet 

Explorer. 

43. Menonaktifkan tombol navigasi Forward dan Back pada Toolbar. 

44. Menonaktifkan pilihan untuk menampilkan/menghilangkan Toolbar 

Internet Explorer. 

45. Menghilangkan Address Bar dari Internet Explorer. 

46. Menghilangkan Links Bar dari Internet Explorer. 

47. Menghilangkan Toolbars/Standard Buttons dari Internet Explorer. 

48. Menghilangkan tombol "Back" dari Internet Explorer Toolbar. 

49. Menghilangkan tombol "Forward" dari Internet Explorer Toolbar. 

50. Menghilangkan tombol "Stop" dari Internet Explorer Toolbar. 

51. Menghilangkan tombol "Refresh" dari Internet Explorer Toolbar. 

52. Menghilangkan tombol "Home" dari Internet Explorer Toolbar. 
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53. Menghilangkan tombol "Search" dari Internet Explorer Toolbar. 

54. Menghilangkan tombol "Folders" dari Internet Explorer Toolbar. 

55. Menghilangkan tombol "Favorites" dari Internet Explorer Toolbar. 

56. Menghilangkan tombol "Media" dari Internet Explorer Toolbar. 

57. Menghilangkan tombol "History" dari Internet Explorer Toolbar. 

58. Menghilangkan tombol "Fullscreen" dari Internet Explorer Toolbar. 

59. Menghilangkan tombol "Tools" dari Internet Explorer Toolbar. 

60. Menghilangkan tombol "MailNews" dari Internet Explorer Toolbar. 

61. Menghilangkan tombol "Size" dari Internet Explorer Toolbar. 

62. Menghilangkan tombol "Print" dari Internet Explorer Toolbar. 

63. Menghilangkan tombol "Edit" dari Internet Explorer Toolbar. 

64. Menghilangkan tombol "Discussions" dari Internet Explorer Toolbar. 

65. Menghilangkan tombol "Cut" dari Internet Explorer Toolbar. 

66. Menghilangkan tombol "Copy" dari Internet Explorer Toolbar. 

67. Menghilangkan tombol "Paste" dari Internet Explorer Toolbar. 

68. Menghilangkan tombol "Encoding" dari Internet Explorer Toolbar 

69. Menghilangkan tombol "PrintPreview" dari Internet Explorer Toolbar 

70. Menghilangkan tombol "Go" dari Internet Explorer Toolbar 

71. Menambahkan label "Shortcut to" pada Internet Explorer Links status bar 

72. Menggunakan Google sebagai Search Engine Standar 

 
G. Login 

1. Logon secara Otomatis Novell Netware Clients pada Windows Network. 

2. Logon secara Otomatis untuk Windows 95, 98 dan Me. 

3. Logon secara Otomatis unruk Windows NT, 2000 and XP. 
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4. Membatasi Auto Logon. 

5. Memaksakan penggunaan Auto Logon. 

6. Menghilangkan user name yang paling akhir Log Off. 

7. Menghilangkan tombol  Shutdown pada Authentication Dialog Box. 

8. Tampilkan Administrator pada Welcome Screen. 

9. Sembunyikan Welcome Screen. 

10. Aktifkan fungsi selalu menekan tombol Ctrl+Alt+Delete sebelum Login. 

11. Aktifkan Fast User Switching. 

12. Menampilkan pesan pada Logon Screen. 

13. Aktifkan Screen Saver pada Logon Screen, jeda waktu. 

14. Mengaktifkan Power-Saving Profile pada Logon Screen. 

15. Menampilkan Option pada Logon Dialog Box. 

16. Menonaktifkan pesan "Unread Mail" pada Welcome Screen. 

17. Memaksakan penggunaan alphanumeric sebagai password. 

18. Tentukan panjang minimum password. 

19. Classic Login Screen. 

20. Wallpaper untuk Classic Login Screen. 

21. Merubah pesan yang tampil pada kotak Logon Klasik. 

22. Membuat tampilan berbeda pada jendela Logon Klasik. 

23. Menampilkan Logon Scripts pada saat dijalankan. 

24. Menampilkan Log Off Scripts pada saat dijalankan. 

25. Menampilkan Startup Scripts pada saat dijalankan. 

26. Menampilkan Shutdown Scripts pada saat dijalankan. 

27. Selaraskan eksekusi Logon Scripts. 
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28. Selaraskan eksekusi Startup Scripts. 

 
H. Start Menu 

1. Mengatur My Computer pada Start Menu. 

2. Mengatur My Documents pada Start Menu. 

3. Mengatur My Pictures pada Start Menu. 

4. Mengatur My Music pada Start Menu. 

5. Mengatur Control Panel pada Start Menu. 

6. Menghilangkan Favorites dari Start Menu. 

7. Tampilkan Favorites  pada Start Menu. 

8. Menghilangkan Network Connections dari Start Menu. 

9. Menghilangkan My Network Places dari Start Menu. 

10. Menghilangkan Recent Documents dari Start Menu. 

11. Menonaktifkan Recent Document. 

12. Menghapus isi Recent Documents saat Windows Shut Down. 

13. Menentukan jumlah maksimal History pada "Recent Documents". 

14. Menghilangkan user name dari Start Menu. 

15. Menghilangkan Control Panel, Printer dan Connect To dari Start Menu. 

16. Menghilangkan "RUN" dari Start Menu. 

17. Menampilkan Pilihan "Run in Separate Memory Space" pada Run Dialog. 

18. Menghilangkan "Search" dari Start Menu. 

19. Menghilangkan "Help" dari Start Menu. 

20. Menghilangkan "Frequent Programs List" dari Start Menu. 

21. Menghilangkan "Pinned Programs List" dari Start Menu. 

22. Menghilangkan “Common Program Groups” dari Start Menu. 
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23. Menghilangkan "Set Program Access and Defaults" dari Start Menu. 

24. Menghilangkan tombol "All Programs" dari Start Menu. 

25. Menghilangkan tombol "Shut Down" / "Turn Off" pada Start Menu. 

26. Menghilangkan "Log Off" dari Start Menu. 

27. Memaksa penggunaan Classic Start Menu. 

28. Menghilangkan Start Menu Subfolders. 

29. Menampilkan sub menu untuk My Pictures pada Start Menu klasik. 

30. Menampilkan sub menu untuk My Documents pada Start Menu klasik. 

31. Menampilkan sub menu untuk Control Panel pada Start Menu klasik. 

32. Menampilkan sub menu untuk Network Connections pada Start Menu 

klasik. 

33. Menampilkan sub menu untuk menu Printers pada Start Menu klasik. 

34. Menonaktifkan klik-kanan pada Taskbar. 

35. Aktifkan Start Menu Scrolling. 

36. Tandai program baru yang ada pada Start Menu. 

37. Menonaktifkan Drag and Drop pada Start Menu. 

38. Menonaktifkan Menu Bar dan Tombol Start Menu. 

39. Menghilangkan setting untuk Taskbar. 

40. Mengunci Taskbar. 

41. Menghilangkan Ballon Tips. 

42. Menghilangkan Toolbars dari Taskbar. 

43. Menghilangkan jam yang terdapat pada Taskbar. 

44. Menghilangkan Tray Items dari Taskbar. 

45. Aktifkan "Auto Hide Inactive Tray Icons (Auto Tray)". 
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46. Membersihkan Past Icons dari Tray Notification. 

47. Aktifkan pengelompokkan Taskbar Buttons yang sama. 

 
I. Startup-Shutdown 

1. Menghapus Page File saat Windows Shutdown. 

2. Atur Lama Response Time untuk aplikasi yang "Macet/Hang". 

3. Otomatis menutup aplikasi yang sedang "Macet/Hang". 

4. Aktifkan Windows Prefetcher Service. 

5. Edit program untuk Windows Startup. 

6. Aktifkan Shutdown Event Tracker. 

7. Menonaktifkan Save Settings at Exit. 

8. Menonaktifkan fasilitas untuk menolak Startup Program. 

9. Otomatis Restart Windows saat 'Blue Screen of Death'. 

10. Menonaktifkan Last Known Good. 

11. Menonaktifkan koneksi Modem secara otomatis pada saat Startup. 

12. Menonaktifkan perintah Run at Startup yang terdapat pada Registry. 

13. Memilih tipe User Based Shell. 

14. Otomatis mengembalikan Windows yang terbuka pada saat Startup. 

 
J. Troubleshooting 

1. Menonaktifkan System Restore pada Start Menu. 

2. Menonaktifkan menu konfigurasi System Restore. 

3. Aktifkan Numlock secara otomatis pada Welcome Screen. 

4.  Aktifkan fasilitas Remote Assistance. 

5. Menonaktifkan semua peringatan pada saat Startup. 
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6. Mengatur besar maksimal ukuran file Cache untuk Icon. 

7. Menonaktifkan Windows Error Reporting. 

8. Menghapus daftar program dari daftar Add/Remove Programs. 

9. Aktifkan Stepping Mode untuk Windows Update. 

10. Menentukan letak direktori untuk menyimpan Small Memory Dump. 

11. Mengirimkan peringatan kepada Administrator bila sistem 'Crash'. 

12. Aktifkan Windows untuk membuat Logs bila Sistem 'Crash'. 

13. Mengaktifkan pembuatan System Crash Dump File. 

14. Menentukan lokasi untuk System Crash Dump File. 

15. Menulis ulang System Crash Dump File. 

16. Menampilkan pesan untuk status keamanan. 

17. Membuat catatan(Log) untuk Windows Installer(MSI). 

18. Memperbaiki Taskbar yang kacau. 

19. Memperbaiki Registry Editor (Regedit) yang kacau. 

20. Memperbaiki Icon yang kacau. 

21. Aktifkan auto logon untuk Administrative pada Recovery Console. 

22. Aktifkan akses ke semua drive pada Recovery Console. 

 
K. Windows Explorer 

1. Menghilangkan menu File dari Windows Explorer. 

2. Menghilangkan menu Folder Option pada Windows Explorer. 

3. Menghilangkan pilihan untuk merubah File Types. 

4. Menonaktifkan setting toolbars pada Windows Explorer. 

5. Menghilangkan pilihan untuk menambah atau mengurangi Toolbars pada 

Windows Explorer. 
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6. Menambah gambar latar untuk Windows Explorer Toolbar. 

7. Menonaktifkan Checkbox "Always use the selected ..." pada "Open With" 

dialog. 

8. Mengubah cara pengurutan file pada Windows Explorer. 

9. Menyingkirkan Folder Shared Documents dari My Computer. 

10. Otomatis membuka sub folder pada Windows Explorer. 

11. Aktifkan Auto Complete pada Windows Explorer. 

12. Menampilkan file sistem operasi Windows yang Tersembunyi. 

13. Menampilkan file dan folder yang tersembunyi. 

14. Membuka folder Windows pada Explorer/Proses yang berbeda. 

15. Mempercepat akses ke file AVI. 

16. Menonaktifkan Cache untuk Thumbnail. 

17. Menghilangkan pilihan "Send To..." pada konteks menu. 

18. Menambah pilihan "Move to..." pada konteks menu. 

19. Menambah pilihan "Copy to..." pada konteks menu. 

20. Menambahkan perintah "Encript / Decript" pada konteks menu Windows 

Explorer. 

21. Menambahkan "Command Prompt" (DOS) pada konteks menu. 

22. Mengaktifkan pencarian untuk semua tipe file pada saat Search File. 

23. Menggunakan interface klasik pada kotak dialog Search File. 

24. Menonaktifkan fungsi kombinasi tombol Windows Hotkeys. 

25. Aktifkan Compressed Folder. 

26. Menonaktifkan Compressed Folder. 

27. Mengubah lokasi direktori untuk Common File dan Program File. 
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28. Larangan akses untuk fitur Windows Update. 

29. Larangan untuk merubah lokasi folder user - My Documents. 

30. Larangan untuk merubah lokasi folder user - My Pictures. 

31. Larangan untuk merubah lokasi folder user - My Music. 

32. Larangan untuk merubah lokasi folder user – Favorites. 

33. Mengubah label CD-Drive. 

 
L. Fungsi-fungsi untuk Main Menu 

1. Edit Registered Owner and Organization 

2. Edit lokasi/direktori file instalasi Windows. 

3. Edit Tips untuk Windows. 

4. Edit Program Alias pada Windows. 

5. Edit lokasi Path sistem dan folder khusus. 

6. Edit informasi OEM dan Logo OEM. 

7. Menyembunyikan drive. 

8. Larangan untuk aplikasi. 

 
3.2.2. Prosedur Windows API 

Untuk mengakses kepada registry, bahasa pemrograman Visual Basic 

memerlukan fungsi Windows API. Fungsi-fungsi Windows API untuk 

menggunakan registry di antaranya ialah sebagai berikut: 

1. RegCloseKey berfungsi untuk menutup nama kunci pada registry. 

2. RegConnectRegistry berfungsi untuk menghubungkan setting 

registry dengan registry komputer lain. 

3. RegCreateKey berfungsi untuk membuat kunci registry. 
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4. RegCreateKeyEx berfungsi untuk membuat kunci registry dengan 

penambahan fungsi lainnya. 

5. RegDeleteKey berfungsi untuk menghapus kunci registry. 

6. RegDeleteValue berfungsi untuk menghapus nilai registry. 

7. RegEnumKey berfungsi untuk mengambil nama kunci dan sub-sub 

nama kunci lainnya, setiap kali fungsi ini dipanggil. 

8. RegEnumKeyEx berfungsi untuk mengambil nama kunci dan sub-

sub nama kunci lainnya setiap kali fungsi ini dipanggil dengan 

penambahan fungsi lainnya. 

9. RegEnumValue berfungsi untuk mengambil nilai dan sub-sub nilai 

lainnya setiap kali fungsi ini dipanggil. 

10. RegFlushKey berfungsi untuk menuliskan semua atribut pada kunci 

registry yang dibuka. 

11. RegGetKeySecurity berfungsi untuk mengambil informasi atribut 

pengaman kunci registry. 

12. RegLoadKey berfungsi untuk meletakkan pada bagian HKEY_USER 

atau HKEY_LOCAL_MACHINE dan menyimpan informasi registry 

pada bagian sub kunci dari file yang dispesifikasikan. 

13. RegNotifyChangeKeyValue berfungsi untuk mengkonfirmasikan 

perubahan pada nilai kunci registry. 

14. RegOpenKey berfungsi untuk membuka kunci registry. 

15. RegOpenKeyEx berfungsi untuk membuka kunci registry dengan 

penambahan fungsi lainnya. 
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16. RegQueryInfoKey berfungsi untuk mengambil informasi kunci 

registry 

17. RegQueryMultipleValues berfungsi untuk mengambil informasi tipe 

dan data registry ke dalam daftar yang dispesifikasikan. 

18. RegQueryValue berfungsi untuk mengambil informasi nilai registry. 

19. RegQueryValueEx berfungsi untuk mengambil informasi nilai 

registry dengan penambahan fungsi lainnya. 

20. RegReplaceKey berfungsi untuk menukar nama kunci registry. 

21. RegRestoreKey berfungsi untuk mengembalikan nama kunci registry 

22. RegSaveKey berfungsi untuk menyimpan nama kunci registry. 

23. RegSetKeySecurity berfungsi untuk menset informasi atribut 

pengamanan kunci registry. 

24. RegSetValue berfungsi untuk menset nilai registry. 

25. RegSetValueEx berfungsi untuk menset nilai registry dengan 

penambahan fungsi lainnya. 

26. RegUnloadKey berfungsi untuk membatalkan pemuatan kunci 

registry. 

Fungsi-fungsi Windows API seperti yang telah disebutkan diatas dapat 

diketahui cara penggunaannya melalui tools dari Visual Basic, yaitu API Text 

Viewer. Melalui tools ini seorang programmer dapat mengetahui deklarasi, 

konstanta ataupun tipe dari Windows API yang dibutuhkan di dalam programnya 

untuk dapat mencapai tujuannya. 
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3.2.3. Rancangan User Interface 

Dalam pembuatan rancangan user interface digunakan konsep interaksi 

manusia dengan komputer dimana seorang user dengan hanya melihat form, user 

akan mudah mengenali apa yang akan dilakukan selanjutnya. 

 
A. Form Make Login 

Form ini bertujuan untuk membuat user name dan password untuk user 

jika user pertama kali menjalankan aplikasi ini. 

 

User Name

Password

Konfirmasi Password

O K C A N C E L

 

Gambar 3.1. Rancangan Form Make Login 

 
B. Form Login 

Form ini akan muncul setiap kali aplikasi dijalankan untuk melakukan 

proses login, sesuai dengan user name dan password yang telah dibuat 

sebelumnya. 

 

User Name

Password

O K C A N C E L

L O G I N

 

Gambar 3.2. Rancangan Form Login 



 43 

 
C. Form Change Login 

Jika ada login, maka diperlukan form untuk mengubah user name dan 

password apabila diperlukan. Oleh karena itu form ini berfungsi untuk memberi 

fasilitas untuk mengubah user name dan password. 

 

User Name

Password

Konfirmasi Password

User Name saat ini

Password saat ini

O K C A N C E L

 

Gambar 3.3. Rancangan Form untuk Mengubah Login 

 
D. Form Utama 

 

Kategori 1

Kategori 2

Kategori 3

Kategori 4

dan seterusnya...

E X I T O K C A N C E L C

 

Gambar 3.4. Rancangan Form Utama 

 
Keterangan : 

Pada bagian A akan diletakkan tombol-tombol kategori sebanyak 11 

buah tombol kategori yang telah disebutkan di atas. Sedangkan pada bagian B 

B 

A 
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akan diletakkan fungsi-fungsi yang tidak dimasukkan kedalam 11 kategori. 

Tombol pada bagian C akan menuju pada form untuk merubah login. 

 
E. Form Kategori 

 
CheckBox1
CheckBox2
CheckBox3
CheckBox4
CheckBox5
CheckBox6
CheckBox7
dan seterusnya...

O K C A N C E L APPLY< B A C K

 

Gambar 3.5. Rancangan Form Kategori 

 
Form tersebut akan berisi fungsi-fungsi yang berupa checkbox sehingga 

user mudah untuk menggunakan aplikasi ini. Tombol Back berfungsi untuk 

kembali pada form utama. 


