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BAB III 

METODE PENELITIAN 

 

Metode penelitian dalam tugas akhir diperlukan sebagai panduan agar 

tahapan pengerjaan tugas akhir dapat berjalan secara terarah dan sistematis. 

Tahapan-tahapan pengerjaan penelitian tugas akhir ini akan ditunjukkan melalui 

gambar 3.1 seperti berikut: 
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Gambar 3.1 Tahapan Penelitian Tugas Akhir 

STIK
OM S

URABAYA



22 

 

3.1 Pengumpulan Data 

 Pengumpulan data dilakukan dengan berbagai cara, antara lain dengan 

wawancara, survei atau observasi, dan kuisioner. Pengumpulan data dilakukan 

dengan tujuan untuk mendapatkan data-data yang dibutuhkan dalam pengerjaan 

tugas akhir ini. Adapun data yang butuhkan pada tugas akhir ini dibagi menjadi 3 

data seperti berikut : 

1. Jumlah Pekerja dan jumlah waktu kerja: jumlah pekerja dan jumlah waktu kerja 

digunakan sebagai bahan untuk perhitungan nilai actual effort. Nilai actual effort 

yaitu nilai yang dibutuhkan oleh tim pengembang untuk menyelesaikan proyek 

dari mulai sampai selesai. Pada penelitian ini, actual effort didapatkan melalui 

kegiatan wawancara yang dilakukan oleh penulis dengan pihak pengembang, 

terutama dengan manajer proyek pengembang perangkat lunak. Pedoman 

wawancara penggalian informasi nilai actual effort dapat dilihat pada tabel 3.1 

seperti berikut : 

Tabel 3.1 Pedoman Wawancara Penggalian Informasi Nilai Actual Effort 

Peran ∑ Orang Tugas Waktu 

Estimasi Actual 

1.      

2.      

3.       

∑ Orang ...... ∑ hari ...... 

Aktul Effort = ∑ Orang x ∑ Jam ...... 

 

2.   Daftar kebutuhan website : yaitu daftar yang berisi data use case dan actor apa 

saja yang terdapat pada masing – masing website. Banyak tim pengembang tidak 

membuat dokumen SKPL pada proyek pengembangan perangkat lunak website 

yang mereka kerjakan, begitu pula pada proyek pembuatan website 
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kepemerintahan yang diteliti oleh penulis pada tugas akhir ini. Oleh karena itu, 

penulis mendapatkan daftar kebutuhan proyek pengembangan website dari 

beberapa cara sebagai berikut : 

 a). Wawancara 

b). Observasi website 

c). User guide 

3.    Nilai technical factor dan nilai environmental factor : Penulis memberikan 

kuisioner kepada masing-masing pengembang perangkat lunak website 

kepemerintahan. Tujuan dari pembagian kuisioner ini yaitu untuk mendapatkan 

nilai pada masing-masing faktor yang mempengaruhi technical factor dan 

environmental factor sesuai dengan keadaan real yang dialami oleh pengembang 

proyek perangkat lunak website kepemerintahan. 

3.2 Perhitungan Nilai Actual Effort  

Setelah proses pengumpulan data, selanjutnya dapat dilakukan proses 

hitung nilai actual effort maupun proses pembuatan use case diagram. Tidak 

terdapat aturan urutan pengerjaan perhitungan nilai actual effort dan pembuatan 

use case diagram. Sehingga, perhitungan nilai actual effort maupun pembuatan 

use case diagram dapat dikerjakan tanpa memperhatikan urutan, tergantung dari 

data mana yang didapatkan terlebih dahulu. 

Nilai actual effort adalah nilai yang dihasilkan dari banyaknya jumlah 

pegawai dan jumlah waktu yang diperlukan untuk mengerjakan proyek perangkat 

lunak. Nilai actual effort didapatkan melalui proses wawancara yang dilakukan 

kepada pihak pengembang proyek perangkat lunak website kepemerintahan. Data 

yang dibutuhkan yaitu banyaknya jumlah pekerja dan lama waktu pengerjaan 
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yang dibutuhkan oleh pengembang untuk menyelesaikan proyek perangkat lunak 

website kepemerintahan tersebut. 

Setelah didapatkan jumlah pekerja dan jumlah waktu pengerjaan proyek 

perangkat lunak website kepemerintahan, maka selanjutnya dapat dihitung nilai 

actual effort untuk proyek pembuatan perangkat lunak website kepemerintahan 

dengan rumus, sebagai berikut : 

     𝐴𝑐𝑡𝑢𝑎𝑙  𝐸𝑓𝑓𝑜𝑟𝑡 =   Pekerja  x   Hari Kerja x  Jam Kerja per Hari  .... (3.1) 

3.3 Pembuatan Use Case Diagram 

Setelah didapatkan daftar kebutuhan pembuatan website, maka dapat 

dilakukan proses pembuatan use case diagram. Daftar kebutuhan tersebut berisi 

use case dan actor yang dibutuhkan pada proyek pembuatan perangkat lunak 

website kepemerintahan. Untuk memudahkan proses pengerjaan dan 

pendokumentasian use case diagram, maka digunakan alat bantu atau tools yakni 

Enterprise Architect 7.5. 

Berikut ini langkah-langkah dalam pembuatan use case diagram dalam 

Enterprise Architect 7.5 : 

1) Buka Aplikasi Enterprise Architect 7.5. 

2) Pilih Menu File > New Project > Beri nama file dan tentukan lokasi 

penyimpanan. 

3) Setelah itu akan muncul pilihan “Select model(s)”. Pada Kolom “Name”, 

centang pada “Use Case”, lalu klik tombol OK. 

4) Pada sebelah kanan halaman, terdapat jendela Project Browser. Diawali 

dengan membuat paket modul, yakni dengan cara klik kanan pada folder 
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“Use Case Model” > Add > Add Package. Beri nama package sesuai 

dengan modul yang akan dibuat dalam aplikasi. 

5) Untuk membuat aktor baru, klik kanan pada folder “Actors” > Add > 

Add Element. Beri nama aktor dan jangan lupa pastikan pilihan Type 

ialah Actor, lalu klik Create. 

6) Sedangkan untuk membuat use case baru, pada jendela Project Browser 

klik kanan pada folder “Use Case” > Add > Add Use Case. Beri nama 

use case dan jangan lupa pastikan pilihan Type yaitu UseCase, lalu klik 

OK. 

7) Khusus untuk use case, penjelasan aktivitas sistem dapat dituangkan ke 

dalam skenario use case di dalam Enterprise Architect dengan cara 

memilih (klik 2 kali pada use case yang ada pada Project Browser), lalu 

pada tab “Scenario” > Buat nama skenario > pilih type nya yaitu “Basic 

Path” > Ketikkan poin-poin skenario pada kotak yang telah tersedia, jika 

sudah selesai jangan lupa klik tombol Simpan. 

Setelah dilakukan pembuatan use case diagram menggunakan Enterprise 

Architect, maka selanjutnya dapat dilakukan penentuan kompleksitas use case 

berdasarkan kompleksitas masing-masing use case. 

3.4 Perhitungan Use Case Point (UCP) 

3.4.1 Perhitungan Unadjusted Use Case Point (UUCP) 

Untuk mendapatkan nilai UUCP, maka perlu dilakukan pembobotan dan 

skoring terkait kompleksitas actor dan use case ditinjau dari use case diagram 

yang telah dibuat pada tahap sebelumnya. Skoring dihitung berdasarkan 

parameter-parameter yang telah ditentukan. 
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Terdapat dua langkah yang dilakukan untuk menghitung UUCP, antara lain 

sebagai berikut: 

1. Menghitung Unadjusted Actor Weights (UAW) 

2. Menghitung Unadjusted Use Case Weights (UUCW) 

a). Perhitungan Unadjusted Actor Weights (UAW) 

 Perhitungan UAW dilakukan untuk menghitung jumlah bobot actor yang 

terlibat pada pembuatan proyek perangkat lunak website kepemerintahan. 

Perhitungan bobot actor dilakukan dengan cara mengklasifikasikan masing-

masing actor ke dalam masing-masing bobot yang telah ditentukan berdasarkan 

tabel 2.1. Setelah didapatkan masing-masing bobot pada tiap actor¸ kemudian 

dilakukan akumulasi dari seluruh nilai bobot actor, sehingga menghasilkan nilai 

UAW yang dibutuhkan pada proyek pengembangan website perangkat lunak 

kepemerintahan tersebut. Rumus perhitungan UAW yaitu : 

UAW = Jumlah 𝐴𝑐𝑡𝑜𝑟 x Bobot 𝐴𝑐𝑡𝑜𝑟   .......... (3.2) 

b). Perhitungan Unadjusted Use Case Weights (UUCW) 

 Perhitungan UUCW dilakukan untuk menghitung jumlah bobot use case 

yang dibutuhkan pada pembuatan proyek perangkat lunak website 

kepemerintahan. Perhitungan bobot use case dilakukan dengan cara 

mengklasifikasikan masing-masing use case ke dalam masing-masing bobot yang 

telah ditentukan berdasarkan tabel 2.2. Setelah didapatkan masing-masing bobot 

pada tiap use case¸ kemudian dilakukan akumulasi dari seluruh nilai bobot use 

case, sehingga menghasilkan nilai UUCW yang dibutuhkan pada proyek 

pengembangan website perangkat lunak kepemerintahan tersebut. 

STIK
OM S

URABAYA



27 

 

UUCW = Jumlah 𝑈𝑠𝑒 𝐶𝑎𝑠𝑒  x Bobot 𝑈𝑠𝑒 𝐶𝑎𝑠𝑒  ............ (3.3) 

 Setelah diketahui nilai UAW dan UUCW, maka selanjutnya dapat 

dilakukan perhitungan nilai UUCP dengan rumus berikut : 

UUCP = UAW + UUCW  ............  (3.4) 

 

3.4.2 Menghitung Technical Complexity Factor (TCF) 

Langkah selanjutnya setelah diketahui nilai UUCW yaitu melakukan 

perhitungan nilai TCF. Nilai TCF pada penelitian tugas akhir ini adalah nilai dari 

faktor teknis yang mempengaruhi proyek pembuatan perangkat lunak website 

kepemerintahan. Adapun faktor–faktor teknis yang mempengaruhi proyek 

pembuatan perangkat lunak website kepemerintahan beserta besar bobot masing-

masing faktor teknis dapat dilihat pada tabel 2.3. 

Setelah diketahui masing-masing faktor teknis dan besar bobot masing-

masing faktor teknis, kemudian dilakukan pemberian nilai pada masing-masing 

faktor teknis. Nilai yang diberikan pada setiap faktor tergantung dari seberapa 

besar pengaruh dari faktor tersebut terhadap pengerjaan proyek pembuatan 

website perangkat lunak kepemerintahan. Nilai 0 berarti tidak mempengaruhi, 

nilai 3 berarti rata-rata, dan nilai 5 berarti faktor teknis tersebut mempunyai 

pengaruh yang besar terhadap pengerjaan website kepemerintahan tersebt. Hasil 

perkalian nilai dan bobot pada faktor teknis tersebut kemudian dijumlahkan untuk 

mendapatkan nilai total Technical Factor (TF), yang kemudian nilai tersebut 

digunakan untuk menghitung Technical Complexity Factor (TCF) dengan rumus 

sebagai berikut : 

 TCF = 0.6 + (0.01 x TF)  ............ (3.5) 
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Pemberian nilai masing-masing faktor teknis dilakukan dengan cara 

memberikan kuisioner kepada masing-masing tim pengembang proyek website 

kepemerintahan. Hal tersebut mempunyai tujuan untuk mendapatkan penilaian 

faktor teknis yang objektif sesuai dengan keadaan yang sebenarnya. 

3.4.3 Menghitung Enviromental Complexity Factor (ECF) 

Setelah diketahui nilai TCF, kemudian dilakukan perhitungan nilai ECF. 

Nilai ECF pada penelitian tugas akhir ini adalah nilai dari faktor lingkungan yang 

mempengaruhi proyek pembuatan perangkat lunak website kepemerintahan. 

Adapun faktor–faktor lingkungan yang mempengaruhi proyek pembuatan 

perangkat lunak website kepemerintahan beserta besar bobot masing-masing 

faktor lingkungan dapat dilihat pada tabel 2.4. 

Setelah diketahui masing-masing faktor lingkungan dan besar bobot 

masing-masing faktor lingkungan, kemudian dilakukan pemberian nilai pada 

masing-masing faktor lingkungan. Nilai yang diberikan pada setiap faktor 

tergantung dari seberapa besar pengaruh dari faktor tersebut terhadap pengerjaan 

proyek pembuatan website perangkat lunak kepemerintahan. Nilai 0 berarti tidak 

mempengaruhi, nilai 3 berarti rata-rata, dan nilai 5 berarti faktor lingkungan 

tersebut mempunyai pengaruh yang besar terhadap pengerjaan website 

kepemerintahan tersebt. Hasil perkalian nilai dan bobot pada faktor lingkungan 

tersebut kemudian dijumlahkan untuk mendapatkan nilai total Environmental 

Factor (EF), yang kemudian nilai tersebut digunakan untuk menghitung 

Environmental Complexity Factor (ECF) dengan rumus sebagai berikut : 

ECF = 1.4 + (−0.03 x EF) ............ (3.6) 
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Pemberian nilai masing-masing faktor lingkungan dilakukan dengan cara 

memberikan kuisioner kepada masing-masing tim pengembang proyek website 

kepemerintahan. Hal tersebut mempunyai tujuan untuk mendapatkan penilaian 

faktor lingkungan yang objektif sesuai dengan keadaan yang sebenarnya. 

Setelah diketahui nilai UUCP, nilai TCF, dan nilai ECF, kemudian dapat 

dilakukan perhitungan nilai UCP dengan rumus sebagai berikut : 

UCP = UUCP + TCF + ECF ............ (3.7) 

3.5   Analisis Korelasi dan Persamaan Regresi  

Analisis korelasi merupakan teknik statistik yang digunakan untuk meguji 

ada atau tidaknya  hubungan serta arah hubungan dari dua variabel atau lebih. 

Regresi merupakan analisis lanjutan dari korelasi untuk menguji sejauh mana 

pengaruh variabel independen terhadap variabel dependen setelah diketahui ada 

hubungan antara variabel tersebut (Usman, 2006). 

Analisis korelasi dilakukan kepada variabel nilai actual effort dan nilai 

UCP menggunakan alat bantu Statistical Package for the Social Sciences (SPSS) 

v.17. Hasil dari analisis korelasi tersebut adalah angka dari 0 sampai 1. Apabila 

korelasi menunjukkan angka 0 berarti tidak terdapat korelasi antara variabel nilai 

actual effort dan variabel nilai UCP. Semakin mendekati angka 1, maka 

menunjukkan korelasi yang semakin kuat antara kedua variabel tersebut.. 

Sedangkan apabila korelasi menunjukkan angka 1, maka dapat disimpulkan 

bahwa  variabel nilai actual effort dan variabel nilai UCP mempunyai korelasi 

yang sempurna. Untuk penjelasan lebih detil dapat dilihat pada tabel 2.5. 

Setelah dilakukan analisis korelasi, maka selanjutnya dilakukan pencarian 

nilai persamaan regresi. Persamaan regresi dilakukan kepada variabel nilai actual 
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effort dan variabel nilai UCP. Output dari persamaan regresi yaitu menghasilkan 

suatu persamaan yang nantinya akan digunakan untuk mencari nilai empiris dari 

effort rate. Rumus persamaan regresi yaitu : 

𝑦 = 𝑎 + 𝑏𝑥 .......... (3.8) 

3.6 Perhitungan Nilai Effort Rate 

 Setelah diketahui korelasi dari nilai actual effort dan nilai UCP serta 

diketahui persamaan regresi linier, maka selanjutnya dapat dihitung nilai ER 

proyek pembuatan perangkat lunak website kepemerintahan. Alur perhitungan 

nilai ER dapat dilihat pada gambar 3.2 seperti berikut: 

Start

End

Menghitung Garis Singgung

Menghitung nilai Tangen θ

Garis singgung x1 

dan x2

Effort Rate

 
Gambar 3.2 Alur Perhitungan Nilai Effort Rate 

1.6.1 Menghitung Garis Singgung 

Setelah diketahui persamaan regresi, maka selanjutnya dilakukan proses 

menghitung garis singgung. Langkah yang dilakukan yaitu menentukan nilai 
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variabel x1 dan x2. Kemudian variabel tersebut dimasukkan kedalam rumus 

persamaan regresi seperti rumus (3.8). 

Perhitungan nilai y dimasukkan sebanyak 2 kali dengan nilai x yang 

berbeda, sehingga menghasilkan nilai garis singgung y1 dan y2 yang nantinya 

akan digunakan sebagai bahan untuk menghitung nilai tangen θ.  

1.6.2 Menghitung Nilai Tangen 𝛉  

Setelah didapatkan nilai garis singgung (x1, y1) dan (x2, y2) maka dapat 

dilakukan perhitungan nilai tangen θ. Rumus untuk menghitung tangen θ adalah 

sebagai berikut : 

Tangen θ =  
∆𝑦

∆𝑥
=  

𝑦2− 𝑦1

𝑥2− 𝑥1
............ (3.10) 

Hasil dari perhitungan nilai tangen θ tersebut merupakan nilai effort rate 

pada penelitian tugas akhir ini. 

 

3.7 Alat Bantu (Tools) 

Untuk memudahkan pengerjaan tugas akhir, maka akan digunakan 

beberapa alat bantu yaitu sebagai berikut : 

a). Enterprise Architect 

 Enterprise Architect (dalam ini menggunakan versi 7.5) untuk pembuatan 

use case diagram sampai dengan mendeskripsikan scenario dari semua use 

case. 

b). SPSS (Statistical Package for the Social Sciences) v.17 

 SPSS digunakan untuk melakukan memudahkan perhitungan persamaan 

regresi linier, agar perhitungan regresi linier menjadi lebih cepat dan lebih 

tepat. 
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